Friday, April 1, 2011

Configure IP Multicast Routing on Cisco Router

Rendezvous Point Routers (two):

ip multicast-routing
!
interface Loopback0
ip pim sparse-mode
!
interface Loopback1
ip address 10.4.40.252 255.255.255.255
ip pim sparse-mode
!
interface Port-Channel1
ip pim sparse-mode
!
interface GigabitEthernet0/0/4
ip pim sparse-mode
!
ip pim rp-address 10.4.40.252 10
access-list 10 permit 239.1.0.0 0.0.255.255

Other Routers:

ip multicast-routing
!
interface Loopback0
ip pim sparse-mode
!
interface Port-Channel1
ip pim sparse-mode
!
interface GigabitEthernet0/0/4
ip pim sparse-mode
!
ip pim rp-address 10.4.40.252 10
ip pim register-source Loopback0
access-list 10 permit 239.1.0.0 0.0.255.255

- The access-list limits the network size the RP is responsible for.
- IP PIM sparse-mode (Protocol Independent Multicast) is enabled on all interfaces.
- Rendezvous Point (RP) should be placed close to IP Multicast sources in core.
- Two or more RPs are configured with the same IP address on loopback interfaces.

5 comments:

  1. Ou dois-je écrire ces lignes???

    ReplyDelete
  2. An IP address is a numeric identifier doled out to each machine on an IP arrange. what is my ip address

    ReplyDelete
  3. This is highly informatics, crisp and clear. I think that everything has been described in systematic manner so that reader could get maximum information and learn many things. free vpns

    ReplyDelete
  4. Good Post, Below is one of another good post for Multicast
    http://www.routexp.com/2018/02/introduction-to-multicast-over-vpn-or.html

    ReplyDelete
  5. Later on, the geolocation by IP feature can help a webmaster know the general location of the visitor. story writing

    ReplyDelete